Connecting GNS3 to Real Networks: Physical Networking with GNS3

By | June 12, 2014

GNS3 (Graphical Network Simulator), best network simulation software allows you to connect and collaborate virtual network topologies to real networks. This awesome feature of GNS3 brings CCNA, CCNP and CCIE labs with zero Hardware! Personally I was much excited when came to know this possibility in GNS3. You might even associate to virtual machines from VMware or VirtualBox to this powerful piece of software. In this GNS3 guide I’m gonna to share connecting GNS3 to real networks. I already shared one article of GNS3 in that we discussed about calculating Idle PC value in GNS3 running over Windows platform. Linking a virtual topology in GNS3 to real devices is very exciting and interesting and which makes business network setup well..

Connecting-GNS3-to-Real-Networks-SPT
Now let me get in to the technical description of virtual network lab.

Tools required

  • GNS3 (Graphical Network Simulator): It is the best network simulator software that is offered for Windows, Linux and MAC. There are many network simulation tools are present like Packet tracer (best CCNA simulator, this will be very useful for CCNA practice test for people who learning CCNA routing), BOSON Netsim etc. The specialties of GNS3 is that it is FREE and we may run real Cisco IOS image in GNS3 router hence you may have realistic experience!

GNS3 network simulation software free download

  • Cisco IOS: Real Cisco IOS is required for running GNS3 labs. Distributing Cisco IOS without license is illegal so you may please Google for IOS.

How to interface or connect GNS3 to real networks?

There are three topologies that we can realize with real networks together with GNS3.
1. Connecting GNS3 topology to Host computer.
With the help of a ‘Microsoft Loop-back adapter’ we can connect GNS3 router to our Host PC
Connecting-GNS3-topology-to-Host-computer

2. Interfacing VirtualBox virtual PCs with GNS3.
GNS3 supports VirtulBox interfacing. Possible to connect GNS3 router to VirtualBox PCs
Interfacing-VirtualBox-virtual-with-GNS3
(I will post on next article)

3. Connecting GNS3 to Internet
Wow! Just amazing! You may possible to implement VPN with this feature. Keep in touch with me, I will be coming with those guides soon.
Connecting-GNS3-to-Internet
As we are starting Real network interfacing I explained the first option in this article (Connecting GNS3 topology to Host computer). I will be posting other two options as soon as possible.

Interfacing GNS3 network to Host computer

The process can be explained with in 3 stages viz creating PC LoopBack network Adapter, Assigning IP Address and Connecting GNS3 virtual network to PC LoopBack Adapter. [My platform is Windows 7]

Stage 1: Creating PC LoopBack network Adapter

For interfacing GNS3 network we should have a dedicated network adapter, don’t worry we can create a Virtual LoopBack adapter in Windows 7, which serves as Physical connection.

Step 1:
Right click on My Computer → Properties → Device Manager
Open-Device-Manager

Step 2:
Right click on the first icon (computer name) then select Add legacy hardware
Add-legacy-hardware

Step 3:
Add Hardware Wizard will appear. This will let you to install driver software for LoopBack adapter. Just click Next
Add-Hardware-Wizard-Windows

Step 4:
Choose manual installation and click Next.
Add-MS-Loopback-Adapter

Step 5:
You will see a list of hardware here, look for Network Adapters, and then click Next
Add-MS-Loopback-Adapter-Windows7

Step 6:
In Select Microsoft Adapter window select Microsoft Loopback Adapter, → Next.
Microsoft-Loopback-Adapter

Step 7:
Now you are ready to install Microsoft Loopback Adapter, click Next to begin installation.
Installing-Microsoft-Loopback-Adapter

Complete the installation by clicking Finish button.
Microsoft-Loopback-Adapter-Windows-7

Stage 2: Configuring Loopback Adapter and Setting up Static IP

Step 1:
Open Networking and Sharing Center by right clicking in the system tray bar icon.
Network-Sharing-center

Step 2:
Click Change Adapter settings.

Change-Adapter-Settings

Here you may find the newly added Microsoft Loopback Adapter. For easy identification I just renamed it in to LoopBack
MS-Loopback-connection

Step 3:
Right click on the Loopback adapter and take Properties, then double click Internet Protocol Version 4 (TCP/IPV4)
Loopback-IP-Adapter

IP-Address-Loopback-windows

Step 4:
Enable the radio button ‘Use the following IP address’ and enter any IP as you like; I used Class A IP 20.0.0.1 with default subnet mask 255.0.0.0
Local-IP-Loopback

Stage 3: Connecting GNS3 virtual network to PC LoopBack Adapter

Now we are gonna to enter to the real meaning of this article, we completed all prerequisites for Interfacing GNS3 with Host computer.

Step 1:
Run GNS3 and add a Router topology to the working area. (I hope you know configuring IOS image for GNS3)
Go to ‘Browse all devices’ then drag a Cloud to the work space area.
Browse-all-devices-GNS3

Step 2:
Right click on the Cloud and Configure.
Configure-Cloud-GNS3

Step 3:
Click C1 node, in the NIO Ethernet tab identify and select the loopback adapter that you created just before. (You may find all the network adapters that is present in your PC, but select only Loopback adapter.)
Cloud-Configuration-GNS3

Click Add button to complete.
MS-Loopback-GNS3-Interface

Step 3:
Interconnect between your Router and the Cloud with Fast Ethernet cable.
Interconnecting-Router-Cloud
Now Run the topology

Start

Step 4:
Console your router by right clicking on the router icon.
Console-GNS3-Router

Step 5:
Configure your router to assign an IP address for FastEthernet 0/0 interface. Configuration commands are followed. (The IP address must be in the same range of Loopback IP and subnet, for me, assigned 20.0.0.2 with 255.0.0.0 subnet)

Connected to Dynamips VM "R1" (ID 0, type c2600) - Console port
Press ENTER to get the prompt.

R1#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
R1(config)#interface fastEthernet 0/0
R1(config-if)#ip address 20.0.0.2 255.0.0.0
R1(config-if)#no shutdown
R1(config-if)#

That’s all, you have done it!

Now try to ping from Router console window to the Host computer and vise versa.
Ping-from-GNS3-Router-to-Host-PC
Pinging from router to Host PC

Ping-from-Host-PC-to-GNS3-Router
Pinging from Host PC to Router


Wow, it is pinging in both directions.!

Is this GNS3 guide helped you? Can I have your feedback please? Share your thoughts using the comment box below.

***   ***   ***

Bonus Tip: You can change the cloud icon for better representation, for that
Right click on the Cloud icon → Change Symbol
Change-Symbol-GNS3

Choose Computer icon from the list.
Symbol-Manager-GNS3

Now you will have better diagram representation
GNS3-Topology

***   ***   ***

In my next article I will be teaching you Interfacing VirtualBox virtual PCs with GNS3. Till then check out some of my Cisco articles. Don’t forget to like our Facebook page to get latest updates.

41 thoughts on “Connecting GNS3 to Real Networks: Physical Networking with GNS3

  1. Daniel Jose Cubero Muñoz

    When i use cloud with router on gns3 i have to desactive my firewall of windows 7, It´s a possible tell the firewall allow loopback conextion without desactive. How i do that?

    Reply
    1. Admin Post author

      Hi Dani,
      You can define custom Firewall rules from the Advanced Firewall settings.

      -Jaseem

      Reply
    1. Admin Post author

      Hi Nounou,
      Glad to know that it was helpful. We’ll be coming up with more GNS3 networking tutorials, stay tuned.

      Reply
  2. timaz

    thanks for your post. it is good to mention that in some cases connecting cloud to the vRouter on GNS might face with some errors like “Server error [-3200] from 127.0.0.1:8000: R1: unable to create generic ethernet NIO” or something like that. in that case, you can restart your machine and the error will disappear.

    Reply
    1. Yasir Saad

      Hi,
      In fact, I had this error, and I realized that GNS3 must be started as ‘administrator’ for this feature to work. That’s the trick for it.

      Reply
  3. Nsiko Samuel

    I have tried this configuration in GNS3 but for some reason the router is not able to ping the cloud and yet I finished connecting the cloud with ip address 192.168.200.2/24 but can ping the network address which is 192.168.200.1/24 on which the cloud is directly connected.

    enable
    configure terminal
    router rip
    network 192.168.100.0
    network 192.168.200.0
    exit
    exit
    configure terminal
    interface FastEthernet0/0
    ip address 192.168.100.1 255.255.255.0
    no shutdown
    exit
    interface FastEthernet0/1
    ip address 192.168.200.1 255.255.255.0
    no shutdown
    exit
    exit
    enable
    configure terminal
    ip dhcp excluded-address 192.168.100.1 192.168.100.10
    ip dhcp pool cyber
    network 192.168.100.0 255.255.255.0
    default-router 192.168.100.1
    dns-server 192.168.200.2
    exit
    exit

    Reply
    1. Nsiko Samuel

      The host ip 192.168.200.2 can ping the router on 192.168.200.1 but the router cannot ping the host

      Reply
      1. Ashish Thakur

        Hi,
        I have followed your steps however i can ping from my cmd to router but cannot do the reverse why so as per your instruction you have done that

        Reply
        1. Ratnesh

          Wells it too late for replying,Anyways it can help somebody like me LOL 🙂

          Just try disabling the windows firewall for public network & it will ping….Thanks 🙂

          Reply
  4. seddeeq


    good morning sir. how are you? i m a student of ccna. my question is why we connect gns3 with real network? and what kind of configuration we can practice after connecting gns3 with real network? please send me

    Reply
  5. JJohnson

    This process has stopped working for me inside of Windows 8 as of a week ago. I use to be able to create loopback adapters that connected my physical PC/VmWare virtual machines directly to my GNS3 environment without fail until recently in Windows 8 the same way I did in Windows 7 “WITH ZERO PROBLEMS.” “It makes absolutely no sense” why I can no longer do this after a simple “reset” of my PC back to factory default. My firewally is deactivated/diasbled (as always) and I’ve gone a step further by turning of Windows Defender as well, but it’s still not working…

    I’m one step from crying “conspiracy theory” against Microsoft because there’s no explanation for the process to “stop” working, thus now requiring you to “share” or “bridge” your loopback connections with a physical adapter in order to now get your physical PC and/or virtually assigned machines to communicate with your VmWare environment… It’s making me wonder “if” during the reset my PC reached out to microft and upon doing so had a script loaded to it that blocks direct loopack adapter communication between GNS3 and loopback adapters (again, that’s just conspiracy theory, “but” it’s REALLY got me wondering at this point.
    Anbody figure this out minus using “sharing,” “bridging,” and all that over “mess/hoops” you have to jump trough just to make a “simple” connection?

    Jay

    Reply
  6. sam

    Hi
    very helpful. Ok now i connected my Gns3 to internet.
    I was wondering if its possible to create a VPN from GNS3 router to a real real Cisco router over the internet? is it possible ?

    Reply
  7. umar

    please help !
    i am using window 8 .i install loop back interface but it is not showing in gns3. what i should do

    Reply
  8. Mateus_CCNA

    Man, it is fcking awsome! I’m studying for CCNA Security and I need to master CCP in GNS3. Your explanation is perfect…

    Reply
  9. illuminaughty

    Thanks for the tutorial. It got me most of the way but….
    I couldn’t get the above to work. I followed this CBT Nugget video and it works like a champ.
    For some reason ip route 0.0.0.0 0.0.0.0 fa0/1 wouldn’t work, even though it was the correct interface.
    I changed my default route to: ip route 0.0.0.0 0.0.0.0 192.168.10.1 (My SOHO router’s address)
    After that I could ping 8.8.8.8

    CBT Nugget on GNS3 and getting out to the interbutts:
    https://www.youtube.com/watch?v=Ipkh2CMedT8

    Reply
  10. kamo

    this course is very usefull.
    thank you for your helping

    Reply
  11. Muhammad

    Hey
    When i want to connect link between router and cloud it did not work !
    Actually nothing did not appear ??????????
    What should i do ?

    Reply
  12. Ismaila

    I need help connecting the cloud to the vRouter. I have tried all means known to me and am still gettin same error message – “Server error [-3200] from 127.0.0.1:8000: R1: unable to create generic ethernet NIO”. Thank you.

    Reply
  13. Mallikarjuna

    After add loopback interface i am not able to git ping from the router ip i hope yet.

    Reply
  14. surajit

    When i am connecting cloud and router it is throwing some error…….” This device can only be connected to cloud on the same host”. can u help me please…

    Reply
  15. Gahoot

    hi all
    can anyone help me out, to connect IOU Switch of GNS3 to physical router or switch, I am tired trying

    Reply
    1. Jared

      At this time, it’s not possible to get IOU virtual switch directly connected to outside network. You have to use a IOS-based virtual switch.

      Reply
  16. Jonathan

    Thanks for this article! I didn’t know that the cloud device could actually be linked to the loopback interface. To think that I’ve been struggling with that on my linux machines… oh boy, well… Thanks!

    Reply
  17. Gurdeep

    Hi All,

    can i ping from one laptop to another laptop gns router ?

    Gurdeep

    Reply
  18. ethem

    hi !

    I have applied the same steps but I couldn’t link any device to the cloud and keep getting this error message.

    Server error from http://127.0.0.1:3080: ESW1: unable to create generic ethernet NIO
    Server error from http://127.0.0.1:3080: ESW1: unable to create generic ethernet NIO
    Server error from http://127.0.0.1:3080: ESW1: unable to create generic ethernet NIO
    Server error from http://127.0.0.1:3080: ESW2: unable to create generic ethernet NIO
    Server error from http://127.0.0.1:3080: SW1: unable to create generic ethernet NIO

    Reply

Leave a Reply

Your email address will not be published. Required fields are marked *