Cisco Enhanced Interior Gateway Routing Protocol EIGRP Configuration Guide – How to configure EIGRP

By | March 28, 2014

In my last article we saw RIP V1 and RIP V2 configurations in detail. Today let’s see IGRP (Interior Gateway Routing Protocol) and EIGRP (Enhanced Interior Gateway Routing Protocol) in details. IGRP is relatively old distance-vector routing protocol formulated by Cisco and today IGRP totally replaced by EIGRP. These are proprietary routing protocol of Cisco, means only Cisco routers capable of configuring IGRP & EIGRP. Like we said in RIP V1 and V2 there is only a small difference between IGRP and EIGRP. It is nothing but the ability of VLSM (Variable Length Subnet Mask) in EIGRP.
After reading this article you may able to do EIGRP configuration between two routers. Here I explained EIGRP configuration with example.
IGRP is a Dynamic Routing Protocol. Readers of this post must aware about difference between Static Routing and Dynamic Routing.

IGRP & EIGRP Configuration

What are IGRP and EIGRP?

  • The major disadvantage of RIP is that it is unable to route traffic if the destination is away from 15 hops. More over RIP fail to identify less populated path as it sticking with Hop count metric, only consider less number Hops. RIP doesn’t check whether the path is populated or busy.
  • (E)IGRP excludes this all the limitations of RIP, It can be used for larger network more than 15 hops! (255 maximum hop count)
  • Assure stable routing even in very large or composite networks. No routing loops should happen.
  • Quick reaction to variations in network topology.
  • Low overhead, means requires small bandwidth to operate.

Cisco EIGRP Metric Calculation

Instead of a simple metric, a combination of metrics is used to choose best path.

The best path is picked out by on a complex metric using:

EIGRP Metric Calculation Equation

If K5 = 0, the reliability term is not included.

It implies metric is proportional to many factors rather than a single parameter as in RIP. Here the metric derived from Internetwork delay, Bandwidth, and Reliability.

The default version of IGRP has K1 == K3 == 1, K2 == K4 == K5 == 0

EIGRP Metric Calculation Equation Solving
Excluding the indeterminate forms we end up with:

Metric={Bandwidth+ Delay}

  • The terms used in the metric computation are not the raw values gained from the #show interface command. But these values are obtained from #show ip route command.
  • (E)IGRP capable of perform Multipath routing, what is Multipath routing? Unlike RIP, which only recalls a single route to any specified target, IGRP can remember up to 4 different paths to any given destination!
  • Multipath routing lets IGRP to balance traffic loads over multiple routes, and protecting against the impacts of link failures.
  • IGRP uses port number 9 for communication

What Autonomous System (AS)

Autonomous-system-AS
(Image credit: http://withfriendship.com)

An Autonomous System (AS) is a single network or a collection of networks that is organized by a common Network Administrator. It is also referred as a routing domain. An autonomous system is allotted globally by a unique number called an Autonomous System Number (ASN). This number often used in IGRP and EIGRP configuration commands.

Cisco EIGRP Example Configuration in Cisco Router

Now I’m going to go to EIGRP configuration example packet tracer. Let’s take the same network scenario that we discussed in RIP configuration as our EIGRP configuration topology. To reduce complexity of this article I removed the IP address assignment steps (Assign IP address to all interfaces in Router 1).

EIGRP Configuration Commands: Router 1

EIGRP Configuration in Router 1

If you got basics of EIGRP let’s get in to EIGRP configuration commands. The network topology yields directly connected networks in Router 1 are Network 1 (10.0.0.0), Network 2 (20.0.0.0) and Network 4 (40.0.0.0).

R1>enable
R1#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
R1(config)#router eigrp 1
R1(config-router)#network 10.0.0.0
R1(config-router)#network 20.0.0.0
R1(config-router)#network 40.0.0.0
R1(config-router)#no auto-summary
R1(config-router)#exit
R1(config)#
R1#
%SYS-5-CONFIG_I: Configured from console by console

R1#copy running-config startup-config
Destination filename [startup-config]?
Building configuration...
[OK]
R1#

Where 1 indicates Autonomous System Number.

Next part is configuration of EIGRP in Router 2

EIGRP Configuration Commands: Router 2

Listen to the network scenario, directly connected networks are Network 3 (30.0.0.0) and Network 4 (40.0.0.0).

EIGRP Configuration in Router 2

R2>enable
R2#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
R2(config)#router eigrp 1
R2(config-router)#network 30.0.0.0
R2(config-router)#network 40.0.0.0
%DUAL-5-NBRCHANGE: IP-EIGRP 1: Neighbor 40.0.0.2 (Serial0/2/0) is up: new adjacency

R2(config-router)#no auto-summary
%DUAL-5-NBRCHANGE: IP-EIGRP 1: Neighbor 40.0.0.2 (Serial0/2/0) is up: new adjacency

R2(config-router)#exit
R2(config)#
R2#
%SYS-5-CONFIG_I: Configured from console by console

R2#copy running-config startup-config
Destination filename [startup-config]?
Building configuration...
[OK]
R2#

These are the EIGRP configuration commands in packet tracer.

Configure EIGRP Using wildcard masks

  • EIGRP supports VLSM (Variable Length Subnet Masking). Here I will show you how to configure EIGRP when administering with Subnet masks.
  • For EIGRP VLSM routing we should use Wildcard Mask, it is nothing but the inverted version of Subnet mask. For example Wildcard Mask of 255.0.0.0 is 0.255.255.255.

I’m gonna to subnet the 10.0.0.0 network to 4 subnets. For easy calculation use this
Online Network Calculator tool: http://www.subnetmask.info/
It lets you to calculate sunetting easy.

The networks are 10.0.0.0/10

Subnets
Subnet mask = 255.192.0.0, Wildcard Mask is calculated by inverting Subnet mask 255.192.0.0 that is 0.63.255.255

Configure EIGRP Using wildcard masks

Now let’s go to configuration.
Router 1: EIGRP Using wildcard masks
Here we included the 0.63.255.255 Wildcard Mask in the configuration commands.

R1(config)#router eigrp 1
R1(config-router)#network 10.0.0.0 0.63.255.255
R1(config-router)#network 10.64.0.0 0.63.255.255
R1(config-router)#network 10.192.0.0 0.63.255.255
R1(config-router)#
%DUAL-5-NBRCHANGE: IP-EIGRP 1: Neighbor 10.192.0.2 (Serial0/2/0) is up: new adjacency

R1(config-router)#exit
R1(config)#
R1#
%SYS-5-CONFIG_I: Configured from console by console

Router 2: EIGRP Using wildcard masks
Router 2 can be configured as the same way

R2(config)#router eigrp 1
R2(config-router)#network 10.128.0.0 0.63.255.255
R2(config-router)#network 10.192.0.0 0.63.255.255
R2(config-router)#
%DUAL-5-NBRCHANGE: IP-EIGRP 1: Neighbor 10.192.0.2 (Serial0/2/0) is up: new adjacency

R2(config-router)#exit
R2(config)#
R2#
%SYS-5-CONFIG_I: Configured from console by console

IGRP Configuration

There is no much difference in IGRP and EIGRP configurations. The routers in the above scenario do not support IGRP, because IGRP is outdated protocol and supported by old versions of IOS. The configuration commands are followed.

R1>enable
R1#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
R1(config)#router igrp 1
R1(config-router)#network 10.0.0.0
R1(config-router)#network 20.0.0.0
R1(config-router)#network 40.0.0.0
R1(config-router)#exit

By comparing IGRP and EIGRP configuration there is not much bigger changes in the commands. Keep in mind IGRP not supported by latest versions of IOS.

How to Remove EIGRP from Cisco Router

Some times you may need to remove EIGRP for updating another protocol or some other reasons. How to disable EIGRP routing in Cisco router? The following commands are used to remove EIGRP from a router.

R1>enable
R1#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
R1(config)#no router eigrp 1
R1(config)#exit
R1#
%SYS-5-CONFIG_I: Configured from console by console

R1#

Configuration commands are completed.

EIGRP Verification and Testing Commands

Now let us familiar some important commands that a Network Admin should know while dealing with EIGRP.

#show ip eigrp topology

This command shows only feasible successors

R1#show ip eigrp topology
IP-EIGRP Topology Table for AS 1

Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,
r - Reply status

P 10.0.0.0/8, 1 successors, FD is 28160
via Connected, FastEthernet0/0
P 20.0.0.0/8, 1 successors, FD is 28160
via Connected, FastEthernet0/1
P 40.0.0.0/8, 1 successors, FD is 20512000
via Connected, Serial0/2/0
P 30.0.0.0/8, 1 successors, FD is 20514560
via 40.0.0.1 (20514560/28160), Serial0/2/0

#show ip eigrp topology all-links

This command displays all neighbors, whether feasible successors or not

R1#show ip eigrp topology all-links
IP-EIGRP Topology Table for AS 1

Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,
r - Reply status

P 10.0.0.0/8, 1 successors, FD is 28160
via Connected, FastEthernet0/0
P 20.0.0.0/8, 1 successors, FD is 28160
via Connected, FastEthernet0/1
P 40.0.0.0/8, 1 successors, FD is 20512000
via Connected, Serial0/2/0
P 30.0.0.0/8, 1 successors, FD is 20514560
via 40.0.0.1 (20514560/28160), Serial0/2/0

#show ip eigrp topology XX.XX.XX.XX

Gives complete EIGRP details of a specified network path. For example lets verify EIGRP over the network 30.0.0.0 [where xx.xx.xx.xx is network address]

R1#show ip eigrp topology 30.0.0.0
IP-EIGRP (AS 1): Topology entry for 30.0.0.0/8
State is Passive, Query origin flag is 1, 1 Successor(s), FD is 20514560
Routing Descriptor Blocks:
40.0.0.1 (Serial0/2/0), from 40.0.0.1, Send flag is 0x0
Composite metric is (20514560/28160), Route is Internal
Vector metric:
Minimum bandwidth is 128 Kbit
Total delay is 20100 microseconds
Reliability is 255/255
Load is 1/255
Minimum MTU is 1500
Hop count is 1

#show ip route

To show updated EIGRP Routing table.

R1#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
* - candidate default, U - per-user static route, o - ODR
P - periodic downloaded static route

Gateway of last resort is not set

C 10.0.0.0/8 is directly connected, FastEthernet0/0
C 20.0.0.0/8 is directly connected, FastEthernet0/1
D 30.0.0.0/8 [90/20514560] via 40.0.0.1, 00:06:01, Serial0/2/0
C 40.0.0.0/8 is directly connected, Serial0/2/0

#show ip route eigrp

Display the route learned through EIGRP only.

R1#show ip route eigrp
D 30.0.0.0/8 [90/20514560] via 40.0.0.1, 00:10:07, Serial0/2/0

#show ip eigrp interfaces

This show command will display all the interfaces participated in the EIGRP process.

R1#show ip eigrp interfaces
IP-EIGRP interfaces for process 1

Xmit Queue Mean Pacing Time Multicast Pending
Interface Peers Un/Reliable SRTT Un/Reliable Flow Timer Routes
Fa0/0 0 0/0 1236 0/10 0 0
Fa0/1 0 0/0 1236 0/10 0 0
Se0/2/0 1 0/0 1236 0/10 0 0

#show ip protocols

To show which routing protocol is used in the router.

R1#show ip protocols

Routing Protocol is "eigrp 1 "
Outgoing update filter list for all interfaces is not set
Incoming update filter list for all interfaces is not set
Default networks flagged in outgoing updates
Default networks accepted from incoming updates
EIGRP metric weight K1=1, K2=0, K3=1, K4=0, K5=0
EIGRP maximum hopcount 100
EIGRP maximum metric variance 1
Redistributing: eigrp 1
Automatic network summarization is in effect
Automatic address summarization:
Maximum path: 4
Routing for Networks:
10.0.0.0
20.0.0.0
40.0.0.0
Routing Information Sources:
Gateway Distance Last Update
40.0.0.1 90 96258
Distance: internal 90 external 170

Ooops! Thats all about EIGRP configuration

RIP or (E)IGRP Which one I should use?

Which one is better RIP (Routing Information Protocol) or (E)IGRP (Enhanced- Interior Gateway Routing Protocol)? Which one I should use?

However I cannot tell you which of these two protocols are better, because networks may vary in lots of ways. You must have complete awareness about these Routing Protocols and your network topology while choosing those.

Routing protocol strictly depends on the network architecture which you are dealing with.
My recommendation is that if you do have the opportunity to use EIGRP, then you have to use it over IGRP or RIP. EIGRP is absolutely an improved routing protocol than both RIP and IGRP.

I hope you guys enjoyed this EIGRP configuration guide. Let me know your comments.

In the next article I will be posting OSPF Configuration in detail.

2 thoughts on “Cisco Enhanced Interior Gateway Routing Protocol EIGRP Configuration Guide – How to configure EIGRP

  1. sandeep

    Hello admin,

    I m network admin at bank,

    i m managing the 27 branch with all router cisoc 1941 cisco 1812,1812 and router cisco 2811 and 3725
    we have two lease line one mpls and one point to point serial

    currently i m using rip 2 for my network and want to upgrade to EIGRP

    can u guide me for better performance

    Reply

Leave a Reply

Your email address will not be published. Required fields are marked *